Main window

Documentation / Community Edition / User Guide / Manager / Main window

Main window

The MyARM-Manager main window opens a welcome screen as shown in Figure "MyARM-Manager welcome screen". It has a menu and a status bar at the top and bottom respectively. The main area is used by selections to present the measurement data. In the following sections the different menus and the status bar are described in detail.

Menu

The MyARM-Manager provides a menu bar as shown in Figure "The MyARM-Manager menu bar" with menus described in the following sections.


Figure: The MyARM-Manager menu bar

File menu

The "File" menu provides menu items to operate on all currently loaded transaction measurements.


Figure: File menu items
"Export all as CSV ..." menu item
Opens a file dialog to select a file to export all currently selected transactions as a comma separated value CSV file.
"Print all ..." menu item
Opens the print dialog (See Print dialog) where the user can select the printer and various printing options such as paper size and orientation.
"Quit" menu item
Quits the MyARM-Manager applications.

Edit menu

The "Edit" menu provides menu items to mark transaction measurements in the table and tree view and allows to copy, print and export these. Moreover a preference dialog allows to edit and save global settings.


Figure: Edit menu items
"Clear marking" menu item
Clears previously marked transaction instances in a table or tree view.
"Mark all" menu item
Marks all loaded transaction instances in a table or tree view.
"Mark region" menu item
After selection of this option the user can mark transaction instances by dragging the mouse from a start until an end row of a table or tree view.
"Copy" menu item
Copies the currently marked transaction instances into the clipboard.
"Export as CSV ..." menu item
Opens a file dialog where the user can select a file to export currently marked transaction instances as a CSV file.
"Print ..." menu item
Opens a print dialog (See Print dialog) to select the printing options for printing the currently marked transaction instances.
"Preferences ..." menu item
Opens a preference dialog where the user can select and save his preferred MyARM-Manager settings. See Preference section below.
"Snapshot Window" menu item
Saves the current dimension and position of the MyARM-Manager on the local hard drive of the current user. Next time the MyARM-Manager is started it opens with the saved dimension and position.
Preferences

At the bottom of the dialog the user can press the Ok button to activate the current settings, the Save button to activate and save the current settings or the Cancel button to discard any changes made within the preference dialog.

The preference dialog supports to change the settings of the MyARM-Manager of various different aspects which can be accessed by the tab-widget at the top of the dialog.

Analysis settings
In Figure "Analysis preferences" all settings are shown which can be changed for transaction analysis.

Within the first Limits box the number of transaction instances which are loaded into the table (Table transactions) or tree (Tree parent transactions) can be configured. An absolute limit of 100.000 transaction instances can not be exceeded.

Within the Tree analysis box the number of transaction instances can be configured which should be highlighted in a transaction tree with the biggest net duration time. With this option it is easy to find the transaction which has the highest execution time (See Tree view focused item context menu ). With the butten Change color a color dialog opens where the user can select the color used for highlighting transaction instances (See Color dialog). The Net duration highlight color is used to highlight any net duration within a transaction tree which is greater than the given percentage according to the overall duration of the root transaction.


Figure: Analysis preferences

Within the Display box various aspects of displaying transaction data can be configured:

Response time
pull-down menu is used to select the unit for displaying transaction response times in either
  • Microseconds
  • Milliseconds
  • Seconds
  • Minutes
  • Hours
  • Days
Date
pull-down menu is used to select the format for displaying dates in the following formats:
DD.MM.YYYY
day.month.year; for example 11.12.2009 for eleventh december 2009.
YYYY-MM-DD
year-month-day; for example 2009-12-11 for eleventh december 2009.
MM/DD/YYYY
month/day/year; for example 12/11/2009 for eleventh december 2009.
DD.MM.YY
day.month.year with two digit year; for example 11.12.09 for eleventh december 2009.
YY-MM-DD
year-month-day with two digit year; for example 09-12-11 for eleventh december 2009.
MM/DD/YY
month/day/year with two digit year; for example 12/11/09 for eleventh december 2009.
Time
pull-down menu is used to select the format for displaying times in the following formats:
HH:MM:SS
hour:minute:second for example 16:29:37 for nearly half past five in the afternoon.
HH:MM:SS.ZZZ
hour:minute:second.millisecond for example 16:29:37.546 for nearly past five in the afternoon including millisecond precision.
HH:MM:SS AP
hour:minute:second in 12-hour clock notation for example 04:29:37 PM for nearly half past five in the afternoon.
HH:MM:SS.ZZZ AP
hour:minute:second.millsecond in 12-hour clock notation for example 04:29:37 PM for nearly half past five in the afternoon including millisecond precision.
Definition tool tip
if enabled within the application and definition tree view Additional information tool tips are shown with more information about the application or transaction definition if the mouse pointer is moved over the definition.

Figure: Export preferences
Export settings
In Figure "Export preferences" all possible settings to configure the CSV export functionality is shown.
Directory
is used to set the default directory to store CSV files. With the Folder button a dialog is opened to browse through the file system to select the directory.
Separator
is used to set the CSV separator character using a pull-down menu. The following charaters are supported:
  • Comma
  • Semicolon
  • Colon
  • Tabulator
  • Space
Add header row
if checked a header row is written at the beginning of each CSV file. The header row briefly describes each column of the CSV file.
Printing settings
In Figure "Printing preferences" all possible settings to configure the printing of transaction instances is shown. There are various printing options which influence the printing output.

Figure: Printing preferences

Within the Generell printing options box the following options can be turned on or off:

Printing header row
if checked a header row is printed describing each column of the printed table.
Print date
if checked the current date is printed as well.
Print border
if checked a border is printed around the table.
Print row number
if checked the row number of the row is printed as the first column of the table.
Use paging
if checked number of rows per page are pre-calculated and on each page the header row is printed (if enabled).
Alternate row color
if checked even and odd rows are colored differently thus each row can be better identified.

Within the File printing options box the directory to save printed files to can be selected.

View menu

The "View" menu provides menu items to show or hide some parts of the MyARM-Manager GUI.


Figure: View menu items
"Selector" menu item
Provides sub-menuitems to show or hide the selector itself and some parts of it.
"Show" menu item
If checked the selector is shown otherwise hidden.
"Transaction DB" menu item
If checked the transaction database selector is shown otherwise hidden. See Transaction database selector.
"Transaction Filter" menu item
If checked the transaction wildcard filter is shown otherwise hidden. See Filtering the definition tree.
"Filter" menu item
If checked the attribute filter is shown otherwise hidden.
"Add Views" menu item
If checked the Add views buttons are shown otherwise hidden.
"Statusbar" menu item
If checked the status bar in the main window is shown otherwise hidden.
"Fullscreen" menu item
If checked the MyARM-Manager window is shown in full screen mode.

Selections menu

The "Selections" menu provides menu items to create new, delete old or switch between selections. All currently created selections are listed at the bottom of the "Selections" menu. A user can open many selections of arbitrary type at a time. The currently supported menu items are:


Figure: Selections menu items
"New Definition Selection" menu item
Creates a new Definition selection.
"New Tree Selection" menu item
Creates a new Tree selection.
"Delete Current Selection" menu item
Deletes the currently shown selection.
"1. Selection: Tree" menu item
First created Tree selection.
"2. Selection: Definition" menu item
Secondly created Definition selection.

Database menu

The "Database" menu allows the user to reload the database, to correlate transactions and to switch between databases. Reloading is extremely useful in cases where the underlying database changes while the user is looking at measurement data.


Figure: Database menu items
"Configure ..." menu item
Allows to switch to another database. This is useful when you have more than one MyARM database available from the same server (in case you have configured a MySQL sink). In case of an underlying SQLite or XML sink a respective file can be chosen.

This menu opens a dialog that has different representations dependent on the configured sink.

The dialog depicted in Figure "The dialog to configure a MyARM-MySQL databases" shows a MySQL database running on localhost with user ruppert and no password. The user and password can be changed. Within the Database box for each of the "definition" database, "application" database and "transaction" database types a filter widget exists which limits the pull-down menu on its left side to the appropriate datanbase names. For example *Def limits the definition database names to all names ending with Def.


Figure: Dialog to configure MyARM-MySQL databases

The dialog as shown in Figure "The dialog to configure MyARM-SQLite database" only allows to change the name of the SQLite file.


Figure: Dialog to configure a MyARM-SQLite database
"Reload" menu item
Reloads all data from the database e.g. new data is shown since last reload or start of the MyARM-Manager.
"Correlate" menu item
Provides menu items to correlate parent/child transaction in the database.
"Full" menu item
Correlates all instances including the ones that were already correlated in a former run. This can be faster for a huge amount of transaction measurements.
"Incremental" menu item
An incremental correlation only correlates transactions that were not yet correlated.

Windows menu


Figure: Windows menu items
"Log Message Window" menu item
Opens or closes a window used to log all MyARM-Manager events. Normally errors are shown directly in the status bar as they occur. Additionally they are logged in the Log Message Window.
"Detailed Window" menu item
Opens or closes the detailed window which shows all transaction details of the transaction in focus (see Detailed Window ).

Help menu


Figure: Help menu items

The "Help" menu gives the user the possibility to read the managers manual and to search for specific help topics and information about the MyARM installation.

"Manual" menu item
opens the Qt-based help browser with the complete MyARM documentation. See also .
"About MyARM" menu item
gives you license and configuration information about the currently installed MyARM edition (not just the manager).

Status bar

MyARM-Manager provides a status bar as shown in Figure "The MyARM-Manager status bar" with the following widgets.


Figure: The MyARM-Manager status bar

Information line

Within the information line of the status bar short help or error messages are displayed during execution of the MyARM-Manager. Each message disappears automatically after 10 seconds.

Progress bar

The progress bar at the right bottom of the main window is used to indicate progress of tasks which may take longer. During such a task the database information widget will blink. Long tasks in that context are:

Database information

In the lower right corner the type of the currently configured sink is shown. By moving the mouse pointer over this information a tooltip comes up which shows more information about this sink (see Figure "The configured sink information with an MySQL database as example" for details).


Figure: The MyARM-Manager database information pop-up